Супер Оферта

★ Искаш безплатен домейн ... https://твоятсайт.com, net, org, info, eu ... тогава може да се включиш в нашата игра ... "Free domain for you"
Sign in to follow this  
Napster

Маршрутен протокол RIP

Recommended Posts

RIP (routing information protocol) e широко използван маршрутизиращ протокол свектор на разстоянието (distancevector).
Той е подходящ предимно за малки мрежи, в които относително рядко настъпват промени в топологията. Всеки ред в маршрутната таблица на RIP маршрутизаторите съдържа информация за направлението, следваща стъпка към това направление и метрика.


Общи положения.

Метриката обозначава разстоянието в стъпки до местоназначението, т.е. метриката използвана от RIP протокола е брой хопове. Максималният брой хопове в една RIP
мрежа е 15.


RIP таймери.

RIP на всеки 30 секунди изпраща копие на маршрутната таблица към съседните маршрутизатори. Таймерът за невалиден маршрут (hold down time) е 180 s. Определя интервала от време, след който даден маршрут се счита за невалиден, ако маршрутизаторът не е получил съобщения за него.
Когато даден път бъде отбелязан като невалиден, се изпращат съобщения с тази информация към съседните маршрутизатори и се преустановява използването му. Тези съобщения се изпращат до изтичането на таймера за изтриване на маршрут (flush timer). След което пътят се изтрива окончателно от маршрутната таблица.


Формат на RIP пакетите.

Първата версия на RIPv1 не поддържа subnet маски, т.е. VLSM, респ. CIDR. Втора версия на протокола - RIPv2, поддържа VLSM, респ. CIDR. Форматът на пакетите на версия RIPv2 е следния:

Формат на RIPv2 пакетите

image.png

Първите три полета Command, Version и Routing domain представляват заглавната част на пакета, а останалите шест полета съдържат данни за маршрути и комбинация от тях може да се повтаря до 25 пъти в един RIPv2 пакет. За пренасяне на информацията от по-големи маршутни таблици се използват няколко
RIPv2 пакета. Полето Command указва дали пакетът съдържа заявка или отговор. Полето Version указва версията на протокола, за RIPv2 тази стойност е 2.
Полетaта Routing domain и Route Tag не се използват и се запълват с нули. Полето Address family е равно на 2, ако следва IP адрес. Ако имаме заявка за цялата маршрутна таблица, е 0.

Сходимост на RIP.
При промяна в топологията на мрежата се налага всички маршрутизатори да преизчислят своите вектори на разстоянията и да достигнат до непротиворечиво описание на новата топология. За увеличаване на скоростта на сходимост на RIP се използват различни методи, например разделяне на хоризонта (split horizon).
Тези методи намаляват вероятността за поява на цикли в маршрутите, но не могат да гарантират отсъствието им.

Максималният брой хопове в RIP е 15. Всяко местоназначение, което е на разстояние над 15 хопа се приема за недостижимо. Това прави невъзможно прилагането на RIP в мрежи с повече от 15 рутера. Но ограничава ситуацията “броене до безкрайност” (Count to infinity), при която могат да се получат цикли в маршрутите.

 

Версии на RIP

RIPv1 (RFC 1058) прилага само classful маршрутизация. Т.е периодичните updates не носят subnet информация. Не е възможно да имаме подмрежи от един и същи клас с различни маски. С други думи, всички подмрежи от даден клас трябва да бъдат с еднакви маски. RIPv2 е разработен през 1994 г. и има възможност да носи subnet информация, да поддържа CIDR. За поддържане на обратна съвместимост с версия 1 запазено е ограничението от 15 хопа. За сигурност е въведена аутентикация с явен текст, подобрена с MD5 (RFC 2082). За да не се товарят хостове, които не са участници в RIP, RIPv2 “мултикаства” обновленията на адрес 224.0.0.9, за разлика от RIPv1, който е broadcast. RIPng (RFC 2080) е разширение на RIPv2 за поддържане на IPv6. - RIPng се базира на RIPv2 – в маршрутната таблица IPv6 префикс, next-hop IPv6 адрес – използва мултикаст (FF02::9) за updates.

 

Конфигуриране на RIP

image.png


Boston Router:

Boston>en
Boston#config t
Boston(config)#router rip
Boston(config-router)#version 2
Boston(config-router)#network 172.16.0.0
!Advertises directly connected networks
(classful address only)
Boston(config-router)#no auto-summary
!Turns off autosummarization
 

Buffalo Router:

Buffalo>en
Buffalo#config t
Buffalo(config)#router rip
Buffalo(config-router)#version 2
Buffalo(config-router)#network 172.16.0.0
Buffalo(config-router)#no auto-summary


Bangor Router:

Bangor>en
Bangor#config t
Bangor(config)#router rip
Bangor(config-router)#version 2
Bangor(config-router)#network 172.16.0.0
Bangor(config-router)#no auto-summary


Конфигуриране на RIP

Router(config)# router rip
Router(config-router)# network 10.0.0.0
Router(config-router)# exit
Router(config)# interface ethernet1
Router(config-if)# ip address 10.1.1.1
255.255.255.0
Router(config-if)# no ip split-horizon
Router(config-if)# exit

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this